通达信没未来函数增强MACD波段公式

【更新时间:2020-08-01 23:10:46】

通达信没未来函数增强MACD波段公式

通达信没未来函数增强MACD波段公式

增强macd波段

 

在MACD的公式上,加入了不同颜色的柱体,加入红绿多空波段。

没有未来函数

{增强MACD波段}

SJ:=1;

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:EMA(DIFF,9);

MACD:=2*(DIFF-DEA)*SJ;

STICKLINE(MACD>=0,MACD,0,2,0),COLORFF00FF;

STICKLINE(MACD>=0 AND MACD<REF(MACD,1),MACD,0,2,0),COLORYELLOW;

STICKLINE(MACD<0,MACD,0,2,0),COLORFFFF00;

STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,2,0),COLORWHITE;

(CLOSE<0 AND CROSS(DIFF,0),H*1.3),COLOR000080,NODRAW;

(CLOSE<0 AND CROSS(MACD,0),H*1.3),COLOR000080,NODRAW;

(CLOSE<0 AND CROSS(0,DIFF),H*1.3),COLOR808080,NODRAW;

(CLOSE<0 AND CROSS(0,MACD),H*1.3),COLOR808080,NODRAW;

MID:=(7*CLOSE+LOW+OPEN+HIGH)/10;

MA0:=MA(MID,40)*SJ;

MA1:=MA(MID,1)*SJ;

A1:=MA1-MA0;

MA2:=MA(MID,2);

A2:=MA2-MA0;

MA3:=MA(MID,3);

A3:=MA3-MA0;

MA4:=MA(MID,4);

A4:=MA4-MA0;

MA5:=MA(MID,5);

A5:=MA5-MA0;

MA6:=MA(MID,6);

A6:=MA6-MA0;

MA7:=MA(MID,7);

A7:=MA7-MA0;

MA8:=MA(MID,8);

A8:=MA8-MA0;

MA9:=MA(MID,9);

A9:=MA9-MA0;

MA10:=MA(MID,10);

A10:=MA10-MA0;

MA11:=MA(MID,11);

A11:=MA11-MA0;

MA12:=MA(MID,12);

A12:=MA12-MA0;

MA13:=MA(MID,13);

A13:=MA13-MA0;

MA14:=MA(MID,14);

A14:=MA14-MA0;

MA15:=MA(MID,15);

A15:=MA15-MA0;

MA16:=MA(MID,16);

A16:=MA16-MA0;

MA17:=MA(MID,17);

A17:=MA17-MA0;

MA18:=MA(MID,18);

A18:=MA18-MA0;

MA19:=MA(MID,19);

A19:=MA19-MA0;

MA20:=MA(MID,20);

A20:=MA20-MA0;

MA21:=MA(MID,21);

A21:=MA21-MA0;

MA22:=MA(MID,22);

A22:=MA22-MA0;

MA23:=MA(MID,23);

A23:=MA23-MA0;

MA24:=MA(MID,24);

A24:=MA24-MA0;

MA25:=MA(MID,25);

A25:=MA25-MA0;

MA26:=MA(MID,26);

A26:=MA26-MA0;

MA27:=MA(MID,27);

A27:=MA27-MA0;

MA28:=MA(MID,28);

A28:=MA28-MA0;

MA29:=MA(MID,29);

A29:=MA29-MA0;

MA30:=MA(MID,30);

A30:=MA30-MA0;

MA31:=MA(MID,31);

A31:=MA31-MA0;

MA32:=MA(MID,32);

A32:=MA32-MA0;

MA33:=MA(MID,33);

A33:=MA33-MA0;

MA34:=MA(MID,34);

A34:=MA34-MA0;

MA35:=MA(MID,35);

A35:=MA35-MA0;

MA36:=MA(MID,36);

A36:=MA36-MA0;

MA37:=MA(MID,37);

A37:=MA37-MA0;

MA38:=MA(MID,38);

A38:=MA38-MA0;

MA39:=MA(MID,39);

A39:=MA39-MA0;

MA40:=MA(MID,40);

A40:=MA40-MA0;

LC:=(A6+A7+A8+A9+A10+A11+A12+A13+A14+A15+A16+A17+A18+A19+A20)/15,LINETHICK0;

VAR1:=LC;

VAR2:=REF(LC,1);

VAR3:=VAR1>VAR2 AND REF(LC,1)<REF(LC,2);

VAR4:=VAR1<VAR2 AND REF(LC,1)>REF(LC,2);

均线发散:STICKLINE(VAR1>VAR2,LC,REF(LC,1),3,0),COLOR0000FF; 

均线粘合:STICKLINE(VAR1<VAR2,LC,REF(LC,1),3,0),COLOR00FF00;

{EMA5:MA(VAR1,5),COLORWHITE;

EMA10:MA(VAR1,10),COLORYELLOW;}

DIFFF:=EMA(CLOSE,21)-EMA(CLOSE,34);

DEAA:=EMA(DIFFF,8);

MACDD:=8*(DIFFF-DEAA);

MARDD:=SMA(MACDD,2,1);