通达信黑马红牛公式

【更新时间:2020-08-01 22:55:41】

通达信黑马红牛公式

通达信黑马红牛公式

&nBSp;{黑马红牛}

VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VAR2:=2*ABS(VAR1);

VAR3:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR4:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR5:=(HIGH+LOW+CLOSE)/3;

VAR6:=(VAR5-MA(VAR5,14))/(0.015*AVEDEV(VAR5,14));

VAR7:=(VAR5-MA(VAR5,70))/(0.015*AVEDEV(VAR5,70));

VAR8:=IF(VAR6>=150 AND VAR6<200 AND VAR7>=150 AND VAR7<200,10,0);

VAR9:=IF(VAR6<=-150 AND VAR6>-200 AND VAR7<=-150 AND VAR7>-200,-10,VAR8);

VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

VARB:=100-ABS(VARA);

VARC:=3*SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);

VARD:=3*SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);

VARE:=REF(LOW,1)*0.9;

VARF:=LOW*0.9;

VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;

VAR11:=EMA(VAR10,30);

VAR12:=VAR11-CLOSE;

VAR13:=REF(CLOSE,1);

VAR14:=SMA(MAX(CLOSE-VAR13,0),7,1)/SMA(ABS(CLOSE-VAR13),7,1)*100;

VAR15:=SMA(MAX(CLOSE-VAR13,0),13,1)/SMA(ABS(CLOSE-VAR13),13,1)*100;

VAR16:=BARSCOUNT(CLOSE);

VAR17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;

VAR18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;

VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

VAR1A:=(SMA(VAR19,4,1)-50)*2;

VAR1B:=SMA(VAR1A,3,1);

VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

VAR1D:=SMA(VAR1C,4,1);

VAR1E:=SMA(VAR1D,3,1);

VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

VAR20:=IF(VAR17<=25 AND VAR18<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR12>=-0.25 AND VAR14<22 AND VAR15<28 AND VAR16>50,80,0);

{情报:=VAR3;}

情报:ABS(100-VAR3),LINETHICK3;

.............

省略部分源码,公式没加密,下载公式导入看源码