通达信区间段涨幅,显示时间段内的涨幅大小公式

【更新时间:2020-08-01 22:53:48】

通达信区间段涨幅,显示时间段内的涨幅大小公式

通达信区间段涨幅,显示时间段内的涨幅大小公式

时间段涨幅 ,

这个公式是:时间段区间涨幅计算主图&nBSp;  

参数两页分别填写你要的时间区间  

 

公式解释:

两根红柱之间代表区间,涨幅数字黄色显示  跌幅蓝色。  

目的是更直观快捷对比个股之间在一个时间段内的涨幅大小。

ps: 另需注意如发现红柱没有显示是当日不属于交易日

 

 

 

{标注,画出柱子}

起点标注:=YEAR=起点年 AND MONTH=起点月 AND DAY=起点日;  {前面时间}

STICKLINE(起点标注,O,C*2.05,0.01,-1),COLORRED;

终点标注:=YEAR=终点年 AND MONTH=终点月 AND DAY=终点日;  {前面时间}

STICKLINE(终点标注,O,C*2.05,0.01,-1),COLORRED;

{计算条件成立的周期数位置}

起点位置:=BARSLAST(YEAR=起点年 AND MONTH=起点月 AND DAY=起点日);

终点位置:=BARSLAST(YEAR=终点年 AND MONTH=终点月 AND DAY=终点日);

中间位置:=(起点位置-终点位置)/2+终点位置;

{涨幅计算}

起点价:=REF(L,起点位置);

终点价:=REF(H,终点位置);

起点价1:=REF(H,起点位置);

终点价1:=REF(L,终点位置);

{分析家公式网 WWW.70822.COM}

时段收盘涨幅:=(终点价/起点价-1)*100;

时段收盘涨幅1:=(起点价1/终点价1-1)*100;

DRAWNUMBER_FIX(终点价>起点价,0.75,0.3,0,时段收盘涨幅),COLORYELLOW;

DRAWNUMBER_FIX(终点价<起点价,0.75,0.3,0,时段收盘涨幅1),COLORCYAN;

DRAWTEXT_FIX(1,0.8,0.3,0,'%'),COLORYELLOW;