通达信公式指标源码:倍量柱主图

通达信公式指标源码:倍量柱主图 MA5:MA(CLOSE,5); MA10:MA(CLOSE,10); MA20:MA(CLOSE,20); MA60:MA(CLOSE,30); MA120:MA(CLOSE,40)COLORFFFF00; MA240:MA(CLOSE,50); DRAWKLINE(H,O,L,C);{重绘K线} RC1:=REF(C,1);

通达信公式指标源码:倍量柱主图

复星医药600196股票最新价格

MA5:MA(CLOSE,5);

MA10:MA(CLOSE,10);

MA20:MA(CLOSE,20);

MA60:MA(CLOSE,30);

MA120:MA(CLOSE,40)COLORFFFF00;

MA240:MA(CLOSE,50);

DRAWKLINE(H,O,L,C);{重绘K线}

RC1:=REF(C,1);

CS:=IF(C>=1,10000,100000);

C涨停10:=1.10*RC1-49/CS;{考虑到4舍5入}

C涨停5 :=1.05*RC1-49/CS;

C跌停10:=0.90*RC1+51/CS;

C跌停5 :=0.95*RC1+51/CS;

ST:=NAMELIKE('S') OR NAMELIKE('*S');

涨停:= IF(ST, C>=C涨停5, C>=C涨停10);

跌停:= IF(ST, C<=C跌停5, C<=C跌停10);

盘中涨停:=IF(ST, H>=C涨停5, H>=C涨停10);

盘中跌停:=IF(ST, L<=C跌停5, L<=C跌停10);

STICKLINE(盘中涨停,H,MAX(C,O),0,0),COLORMAGENTA;{涨停后回落}

STICKLINE(盘中跌停,L,MIN(C,O),0,0),COLORLICYAN;{跌停后回升}

假阴:=C<O AND C>REF(C,1);STICKLINE(假阴,O,C,1.5,0),COLORMAGENTA;{假阴柱};

假阳:=C>O AND C<REF(C,1);STICKLINE(假阳,O,C,1.5,0),COLORLIGREEN;{假阳柱};

T1B:=CONST(LLVBARS(LOW,10));

T1HIGH:=CONST(REF(HIGH,T1B));

CC:=CONST(CURRBARSCOUNT);

T2B:=CONST(BARSLAST(CURRBARSCOUNT>CC+T1B AND H>T1HIGH));

T2HIGH:=CONST(REF(HIGH,T2B));

T3:=CONST(BARSLAST(CURRBARSCOUNT>CC+T2B AND HIGH>T2HIGH));

T3HIGH:=CONST(REF(HIGH,T3));

必杀线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),COLORRED,LINETHICK3;{,LINETHICK2,COLOR0000FF;}

MA5K:必杀线,COLORYELLOW,LINETHICK1;

趋红:"CYX.NOTEXT1" DOTLINE,COLOR0000FF;

趋篮:"CYX.NOTEXT2" DOTLINE,COLORBLUE;

DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))

AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.95,9) ;

DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2))

AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.1,15);

VAR3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

VAR5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

VAR6:=(VAR3+VAR4+VAR5)/3;

VAR7:=EMA(VAR6,5);

ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK;

VAR8:=IF(VAR6<=-20,10,0);

VAR9:=HHV(VAR8,10);

VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);

K:=EMA(VAR7,5)*2, , COLORFF00FF;

D:=EMA(K,5), , COLORWHITE;

J:=K*3-D*2, ,COLORYELLOW;

VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;

HS:=VOL/CAPITAL*100, , COLORGREEN;

DRAWTEXT(VAR8=10 AND FILTER(VAR8=10,5),LOW*1.00,'准备') COLORMAGENTA;

DRAWTEXT(VARA=20,LOW*1.00,'要买') COLORRED;

DRAWICON(VARA=20,LOW*1.00,1);

VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,'异'),LINETHICK1,COLORFF00FF;

VAR12:=(HIGH+LOW+CLOSE)/3;

VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));

VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));

VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);

VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);

VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

VAR18:=100-ABS(VAR17);

VAR19:=IF(VAR18<90,VAR18,100);

VAR1A:=IF(VARE>0,VARE,0);

VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;

VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;

DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*1.00,'大') COLORYELLOW;

VAR20:=PEAKBARS(3,15,1)<10;

VAR21:=IF(VAR20=1,2,0);

VAR22:=IF(VAR21=2,2,0);

VAR23:=IF(VAR22>REF(VAR22,1),35,0)LINETHICK2;

DRAWTEXT(VAR23=35,HIGH*1.00,'一定要逃')COLORGREEN,NODRAW;

DRAWICON(VAR23=35,HIGH*1.00,2);

STICKLINE(C>1.095*REF(C,1) AND C=H,O,C,1.5,0)COLORYELLOW;{涨停黄K};

A7:=C-REF(C,1);

A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);

买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));

DRAWTEXT(FILTER(买=1,5),LOW-0.3,'买'),COLORYELLOW;

STICKLINE(买,OPEN,CLOSE,1,0),COLORYELLOW;

N:=20;

左峰高:=REF(HHV(C,N),1);

倍量过左:=REF(COUNT(C<左峰高,2)=2,1) AND C>左峰高 AND C>O AND VOL/REF(VOL,1)>=1.9;

DRAWTEXT(倍量过左,((CLOSE-OPEN)*1.5)+H,'倍'),COLORYELLOW;

DIFF0:=(EMA(DCLOSE,12)-EMA(DCLOSE,26))*100;

DEA0:=EMA(DIFF0,9);

MACD:=2*(DIFF0-DEA0);

JQ:=MACD>REF(MACD,1)*2.5 AND MACD>15 AND DIFF0>0 AND DEA0>0;

DRAWTEXT(FILTER(JQ=1,2),L-0.1,'追'),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=5+1,L/1.035,'5');{扣低图标}

DRAWTEXT(CURRBARSCOUNT=10+1,L/1.035,'10');

DRAWTEXT(CURRBARSCOUNT=20+1,L/1.035,'20');

DRAWTEXT(CURRBARSCOUNT=60+1,L/1.035,'60');

DRAWTEXT(CURRBARSCOUNT=120+1,L/1.035,'120');

DRAWTEXT(CURRBARSCOUNT=240+1,L/1.035,'240');

DRAWTEXT(CURRBARSCOUNT=3,HIGH*1.02,'3'), COLORGREEN;{斐波纳奇数,时间变盘窗口}

DRAWTEXT(CURRBARSCOUNT=5,HIGH*1.02,'5'), COLORGREEN;

DRAWTEXT(CURRBARSCOUNT=8,HIGH*1.02,'8'), COLORGREEN;

DRAWTEXT(CURRBARSCOUNT=13,HIGH*1.02,'13'), COLORGREEN;

DRAWTEXT(CURRBARSCOUNT=21,HIGH*1.02,'21'), COLORGREEN;

DRAWTEXT(CURRBARSCOUNT=34,HIGH*1.02,'34'), COLORGREEN;

DRAWTEXT(CURRBARSCOUNT=55,HIGH*1.02,'55'), COLORGREEN;

{智能交易}

VAR1:=(C+H+O+L)/4;

TR1:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));

ATR:=MA(TR1,13);

VAR71:=REF(CLOSE,1)-REF(ATR,1);

LSX:=HHV(VAR1,13),LINETHICK1,COLORLIBLUE;

智能交易:HHV(VAR1,13)*0.95,COLOR0000FF;

支付宝转账赞助

支付宝扫一扫赞助

微信转账赞助

微信扫一扫赞助

【股友股评】: