通达信公式指标源码:MACD分析主力

通达信公式指标源码:MACD分析主力 VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL); OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0); OBV2:=EMA(OBV1,3)-MA(OBV1,9); OBV3:=EMA(IF(OBV2>0,OBV2,0),3); MAC3:=MA(C,3); SHORT:=12;L

通达信公式指标源码:MACD分析主力

复星医药600196股票最新价格

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

OBV2:=EMA(OBV1,3)-MA(OBV1,9);

OBV3:=EMA(IF(OBV2>0,OBV2,0),3);

MAC3:=MA(C,3);

SHORT:=12;LONG:=26;MID:=9;

DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;

DEA:EMA(DIF,MID)COLORFF9900 ;

主力买:IF(DIF>REF(DIF,1),DIF,0),NODRAW;

主力卖:IF(DIF<REF(DIF,1),DIF,0),NODRAW;

MACD:=(DIF-DEA)*2;

STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,1.2,0),COLORYELLOW;

吸:=MACD<0 AND MACD>REF(MACD,1);

拉:=MACD>0 AND MACD>REF(MACD,1);

派:=MACD>0 AND MACD<REF(MACD,1);

落:=MACD<0 AND MACD<REF(MACD,1);

STICKLINE(吸,0,MACD,0.5,0),COLORRED;

STICKLINE(拉,0,MACD,0.5,0),COLORRED;

STICKLINE(派,0,MACD,0.5,0),COLORGREEN;

STICKLINE(落,0,MACD,0.5,0),COLORWHITE;

主力吸筹:吸,COLORYELLOW,NODRAW;

主力拉升:拉,COLORRED,NODRAW;

主力派送:派,COLORGREEN,NODRAW;

主力砸盘:落,COLORFFAA00,NODRAW;

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

低位金叉:CROSS(DIF,DEA) AND DIF<-0.1,COLORWHITE,NODRAW;

二次金叉:CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,COLORRED,NODRAW;

STICKLINE(低位金叉,0,0.08,2,0),COLORFF00FF;

DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

底背离:REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA),COLORGREEN,NODRAW;

STICKLINE(底背离,0,0.03,2,0),COLOR00FF00;

DRAWTEXT(底背离,0.12,'底背离'),COLORFF00FF;

双金叉:低位金叉 AND 二次金叉,COLORFF00FF,NODRAW;

三全项:低位金叉 AND 二次金叉 AND 底背离,COLORWHITE ,NODRAW;

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);

STICKLINE(二次金叉,0,0.06,2,0),COLORFFCC00;

DRAWICON(二次金叉,DEA*0.9,1) ;

DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;

DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;

IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;

IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORGREEN,LINETHICK2;

支付宝转账赞助

支付宝扫一扫赞助

微信转账赞助

微信扫一扫赞助

【股友股评】: